Connectivity issues across accounts and devices USA

Incident Report for Nayax

Identified

Our partner has a network issue they are working on. We are monitoring the situation while they are working on fixing the root cause and are now working on re-establishing consistent support to our network.
Posted May 21, 2026 - 22:14 IDT

Update

We are continuing to investigate the issue.
Posted May 21, 2026 - 21:39 IDT

Investigating

Our team is collaborating with our partners to resolve connectivity issues currently being experienced in USA. We will keep you updated with more information when we have it. Thank you for your understanding.
Posted May 21, 2026 - 20:11 IDT
This incident affects: Latin America (Transactions) and North America (Transactions).